Support SPI slave for SAM9g25

Discussion around AT91RM9200 and SAM9 Series Products.

Moderator: nferre

ramgopikrishna
Posts: 1
Joined: Tue May 28, 2019 9:17 am

Support SPI slave for SAM9g25

Tue May 28, 2019 9:23 am

Hi,

We are using SAM9g25 processor and kernel linux 3.10 version. The processor supports Master/Slave which I got it from data-sheet but when
I looked kernel and it supports only master interface, I hope the driver will be supported by Atmel. Please some one share the link or patch or the kernel version which supports the slave of sam925.
blue_z
Location: USA
Posts: 1912
Joined: Thu Apr 19, 2007 10:15 pm

Re: Support SPI slave for SAM9g25

Wed May 29, 2019 12:36 am

You would need to use Linux kernel version 4.13 or later for framework that supports SPI slave mode.
However the Atmel SPI device driver, spi-atmel.c, only supports supports master mode.

You will have to write your own driver for SPI slave mode.

BTW the SAM9G25 is a SoC that has a ARM926EJ-S processor.
The SPI controller is part of the SoC, not the processor.

Regards

Return to “SAM9 ARM9 MPU”

Who is online

Users browsing this forum: No registered users and 7 guests